DISLIN Soft- und Hardware-Voraussetzungen

Im Augenblick werden die folgenden Compiler und Betriebssysteme on DISLIN unterstützt:

Hardware

Operating System

Compiler

IBM-PC

MS-DOS

gcc (DJGPP)
g77 (DJGPP)
IBM-PC
Windows
Absoft Fortran 8.x, 9.x
Absoft Fortran 10.x, 11.x
Borland C++ 5.5, 6.0
C/C++ interpreter Ch
Digital Mars C/C++
Digital Visual Fortran 5.x, 6.x
gcc/g77/g95/Perl/Python Cygwin
gcc/g77,g95 MinGW
GNU Fortran
Intel compilers icc, ifort
Java 1.x
Lahey LF90 3.x, 4.x
Lahey LF95 5.x
LCC-Win32
Open Watcom wcl, wfl 1.x
Perl 5.8.0, 5.10.1, 5.14.2 ActiveState
Portland Group PGF77, PGF90, PGF95
Python 2.5, 2.6, 2.7, 3.1, 3.2
Ruby 1.9.3
Salford FTN77, FTN90, FTN95
Tcl 8.5 ActiveState
Visual C++
IBM-PC
Linux
gcc, g77, g95, gfortran,
Absoft f77, f90, f95,
Intel ifort, icc,
Portland pgf77, pgf90, pgf95,
Sun Studio compilers,
Java, Perl, Python, Ruby, Tcl, Ch
IBM-PC
FreeBSD
gcc, f77, gfortran
Perl, Python, Ruby, Tcl
IBM-PC
.NET
C#, Visual C++ .NET, Visual Basic .NET
IBM-PC
Solaris 10, x86
cc, f77, f90,
Perl, Python, Java
AMD64 / Intel EM64T
Windows 64-bit
Absoft Fortran 10.x, 11.x
gcc, gfortran MinGW64
Intel icc, ifort
Portland pgf77, pgf95
Python 3.1, 3.2
Visual C++ 8.x
AMD64 / Intel EM64T
Linux 64-bit
gcc, g77, g95, gfortran,
Absoft f77, f90, f95,
Intel icc, ifort,
Portland pgf77, pgf90, pgf95,
Sun Studio compilers,
Java, Perl, Python, Ruby, Tcl, Ch
AMD64 / Intel EM64T
FreeBSD 64-bit
gcc, f77, gfortran
Perl, Python, Ruby, Tcl
AMD64 / Intel EM64T
Solaris 10, AMD64
cc, f77, f90,
Perl, Python, Java
Intel Itanium
Linux 64-bit
gcc, g77
Intel icc, ifort
HP Integrity
HP-UX 11i
f77, cc, f90,
Perl, Python
Mac Intel
Darwin / Mac OSX
gcc, g77, g95, Perl, Python, Intel icc, ifort
DEC-ALPHA
OpenVMS 6.x, 7.x
FOR, CC, F90
DEC-ALPHA
Tru64 UNIX 4.x, 5.x
f77, cc, f90,
Java, Perl, Python
SUN Sparc
SunOS 5.x
f77, cc, f90,
Java, Perl, Python

 
loading content